HMRC Data validation Error 3317 in Computations UK Taxonomies CT600 submission rejected

HMRC CT600 Data validation Error 3317 in Computations UK Taxonomies (UK GAAP or UK IFRS)

Symptoms:

When submitting CT600 return with attachment of Computations in iXBRL format for an accounting period on or after 1st April 2017, HMRC servers may reject the submission with a HMRC validation:

  • Error Number: 3317
  • Error Location: Computations
  • Error Type: business
  • Error Text: If you are trying to use one of the recognised UK Taxonomies (UK GAAP or UK IFRS) there appears to be an error in the Taxonomy reference - please contact your software supplier. If you are trying to use any other taxonomy it may be that it is not supported by HMRC's systems, please contact Online Services Helpdesk on 0845 60 55 999.

Cause:

HMRC updated their servers with a new entry point in Computations DPL Taxonomy. This means computations using one of the recognised UK Taxonomies (UK GAAP or UK IFRS) for accounting period starting on or after 01/04/2017 appears to have an error in the Taxonomy reference. Hence it is being rejected with HMRC data validation Error 3317.

Solution:

  1. Where you are receiving this error and have attached Computations iXBRL file created through a third party Final Accounts Production software or have had your Computations tagged, please contact your software provider for updates they may have for the new computations taxonomy.

  2. Solution below is only applicable if you are using the free in-built Computations iXBRL template within Andica CT600 software.

These are the possible solutions:

Instructions on how to install an update

Important: This option should only be used by customers who are on CT600 Version 2018 software for Accounting Periods up to 31 March 2019, Single User (Single computer) licence, any number of Companies bandwidth.

Version number displayed on software login screen would be:

Version 2018.0.0.0

Customers using Network (Multi user) version of CT600 Version 2018 should contact us by email.

Instructions on how to install an update

Warning: This update is for version 2018 only. Customers using older versions 2017 or earlier should NOT apply this patch, you will break that software and there is nothing we can do about it.

Customers with Andica CT600 versions listed above should click this link to download and apply a patch to Andica CT600 Version 2018.


Important: This option should only be used by customers who are on CT600 Version 2017 software for Accounting Periods up to 31 March 2018, Single user (Single computer) licence, any number of Companies bandwidth.

Version number displayed on software login screen would be:

Version 2017.0.0.0 to Version 2017.0.0.4

Customers using Network (Multi user) version of CT600 Version 2017 should contact us by email.

Instructions on how to install an update

Warning: This update is for version 2017 only. Customers using version 2016 or earlier versions should NOT apply this patch, you will break that software and there is nothing we can do about it.

Customers with Andica CT600 versions listed above should click this link to download and apply a patch to Andica CT600 Version 2017.


Customers using older versions of Andica CT600 will need to purchase an upgrade to the next version up.

Details for CT600 customers purchasing and upgrading their existing version can refer to the CT600 FAQ page which provides information for upgrading from one version to the next version.


How to install an update: 

When you click on the download links, your computer's internet browser takes over the rest of download functions, we do not control that. Your computer's browser will guide you through the download process. 
  1. Close the software before installing the update.

  2. To download the update, click on the download link provided above.

  3. If prompted, click Run or Save. Preferably 'Save' the file in a convenient location. It is most likely that your computer's browser will automatically save this file into a Downloads folder.

  4. If you have saved the file, double click on the downloaded file to start installation. If you have chosen to 'Run' installation will start.

  5. Follow the prompts given by the installer. Your system may require you to permit installation.

  6. Important: Check location shown in 'Unzip to folder'.

    Extract the updates into the location where the Andica CorpTax software is installed. If you have installed the software in a different location, change the path shown in 'Unzip to folder' or 'Browse' to the location where you have installed the software.

    Refer to 'Software updates installation location' below for further details.

  7. Click 'Unzip'.

  8. Once the updates have been extracted, 'Close' the extractor. You can now start the software and use it to process your returns.

Software updates installation location:
  • The default software installation location for CT600 software would normally be:
  • For computers with 64-bit Windows OS - "C:\Program Files (x86)\Andica\Andica CorpTax"
  • For computers with 32-bit Windows OS - "C:\Program Files\Andica\Andica CorpTax"
To find out where the software is installed on your computer:
  1. Right click on the software startup icon on your desktop (Ensure you are clicking on the correct software icon)
  2. Select 'Properties'
  3. View 'Shortcut' tab
  4. The path is displayed in 'Target' field.

Check for that location through Windows Explorer. Ensure you extract updates into that location.


Disclaimer: Apart from the information already provided above we cannot advice on how to install the software and updates on your computer. We also cannot advise on how you should configure your computer or resolve your computer system issues. Information provided here is given without any obligations and we will not accept any claims or liabilities for any damages as a result of you relying on the information given here, if in doubt you must consult a qualified Windows system engineer.
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